読者です 読者をやめる 読者になる 読者になる

flyway-sbt の依存が解決できなくなった

半年前くらいに書いたプロジェクトを再び実行しようとしたらCircleCIでエラーが出てきた。

gist.github.com

エラーの内容はFlywayがダウンロードできないだけなんだけど、以前動いてたものだったので原因がさっぱりわからず。

↓当時置いてた project/flyway.sbt gist.github.com

一応Issueは上がってて解決したっぽいことが書いてあるけどまだ解決してないのかな。

flyway-sbt is not resolved · Issue #1281 · flyway/flyway · GitHub

追記

もう少し調べてみたところSame Issueも上がっていてrepositoryのurlをhttpsにすれば解決するとのこと。 SBT plugin published to wrong location in Maven Central · Issue #1276 · flyway/flyway · GitHub

試しにhttpsにしたところうまく行った…

解決した project/flyway.sbt gist.github.com